[ dendic @ 26.11.2013. 19:47 ] @
Na web serveru pod debianom lenny prijavljuje mi nakon apache2 restart da nedostaje libphp5.so Uradio bi #apt-get libapache2-mod-php5 ali mi javlja da mi je stara source lista u etc/apt/source list. Sta mi je ciniti mogu li prekopirati odnekle samo taj file ili da nadjem neku source listu koja jos uvijek radi za taj stari debian?
[ Miroslav Strugarevic @ 27.11.2013. 13:38 ] @
Postavi gresku.
[ dendic @ 27.11.2013. 13:54 ] @
apache2 restart nece, apache2 -k start prijavljuje nedostatak libphp5.so fajla, apt-get install libapache2-mod-php5 ne ide jer mi je stara source lista u etc/apt.Ima li kakva source lista za debian lenny da je aktivna ?
Uglavnom server ne radi,a php -v uredno javlja verziju.

[Ovu poruku je menjao dendic dana 27.11.2013. u 15:10 GMT+1]
[ Miroslav Strugarevic @ 27.11.2013. 14:55 ] @
http://archive.debian.net/lenny/libapache2-mod-php5
http://www.howtoforge.com/usin...-versions-in-your-sources.list
[ dendic @ 28.11.2013. 11:03 ] @
ovaj donji link ne radi vezano za source.list
gornji link,skino sam libapache2...deb
instaliro ga sa dpkg -i libapache2......deb
apache2 -k restart daje gresku Apache is running a threated MPM...you need to recompile,sta mi je ciniti ? ovakva je sad greska kao na donjem linku
http://www.apachelounge.com/viewtopic.php?p=13816
Dell je server poweredge1650,mozda sam trebo instalirat IA64 paket libapache2-mod-php5 umjesto za i386 arhitekturu??
[ Miroslav Strugarevic @ 28.11.2013. 12:48 ] @
Jel ti ovo test ili prod. server?
[ dendic @ 28.11.2013. 13:30 ] @
nije testni,server vrti jednu profi stranicu,vjerovatno sam trebo neku verziju libapache2...deb naci da je threadsafe,jel dovoljno sto koristim komandu dpkg -i libapache2.....deb ili i tu ima neŇ°to da bi se stvar pravilno raspakovala dpkg -buildconfig ..Moze li se na apachu iskljucit negde ova opcija MPM pa da stvar proradi?
[ Miroslav Strugarevic @ 28.11.2013. 16:17 ] @
Nisam siguran. Mozda da pogledas ovo? http://stackoverflow.com/quest...p-and-apache-thread-safe-error

Trenutno nemam vremena da ovo proverim sto znaci da sve ovo radis na svoju odgovornost :)
[ Miroslav Strugarevic @ 28.11.2013. 20:34 ] @
Da li je taj apache web server ikada radio sa PHP-om? Da li ga je neko konfigurisao pre tebe? Sto vise informacija dobijem/o, bolji odgovor ces da dobijes.
[ dendic @ 28.11.2013. 20:50 ] @
Naravno da je radio do pre neki dan.Onda je stao,apache2 restart prijavljivao nedostatak libphp.so, sutra cu uradit dpkg -r za libapache2-mod-php5 sto sam danas instaliro.Imam osjecaj da mi jedino preostaje to instalirat odnekle libapache2-mod-php5 samo ne znam sad kako pogoditi verziju koja podrzava i ia64 arhitekturu i taj MPM thread.Ne mogu nigdje da nadjem neku archive.security lenny podrsku koju bi ukuco u etc/atp/source.list
[ Miroslav Strugarevic @ 28.11.2013. 20:53 ] @
Da ti nije "ostecen" fajl sistem ili nesto slicno posto ne mogu da verujem da je to sve prestalo da radi samo od sebe.

p.s. Mozes pogledati i ovo: http://serverfault.com/questio...th-apt-get-apache2-mpm-prefork
[ dendic @ 28.11.2013. 21:40 ] @
A sta mi sad preostaje nego da probam ovo zakrpiti,najvjerovatnije si u pravu da je u pitanju nesto oko file sistema,javit cu ako sta uradim
[ Miroslav Strugarevic @ 28.11.2013. 21:57 ] @
Baci pogled na last, history i dmesg cisto da vidis da li se nesto desava sto ne bi trebalo :) Javi kako si resio problem, voleo bih da znam.

Pozdrav!
[ dendic @ 30.11.2013. 12:44 ] @
Uspjeo sam naci source listu koja radi za apt-get ...ftp.de i sve je proradilo

http://www.redirect301.de/debian-lenny-sources-list-2012.html